Bienvenue! Inscrivez-vous et rejoignez notre communauté :)
  • Login:

Bienvenue sur Forum SIG - Systèmes d'Information Géographique et Géomatique.

Bienvenue sur le forumSIG. S'il s'agit de votre première visite, assurez vous de faire une recherche préalable dans les FAQ SIG. Vous devez vous inscrire avant de pouvoir poster.

Affichage des résultats 1 à 5 sur 5
  1. #1

    Date d'inscription
    février 2012
    Emploi
    Administrateur SIG
    Organisme
    Agence d'urbanisme
    Messages
    50

    Mes réseaux sociaux

    Add infoble on Google+

    Par défaut Installation Lizmap 3.2 / nginx

    Bonjour,
    je me relance dans une installation de lizmap sur un serveur fraîchement mis à jour.
    Serveur : debian stretch, nginx, php7.2, mode FPM/FastCGI actif
    Qgis-mapserver semble être fonctionnel (j'ai le xml du getcapabilities qui s'affiche), j'installe lizmap en suivant toutes les étapes (set_rights.sh, ajout du module demo, installer.php, re set_rights.sh) et tout semble se dérouler correctement.
    Seulement à l'affichage de l'url, premièrement la miniature du projet montpellier ne s'affiche pas et les liens vers le projet ou vers la page de login me renvoient vers cette même page. (test) Il m'est donc impossible d'aller plus loin
    Je n'ai rien dans les logs... Je suis donc preneur d'une piste de direction dans laquelle poursuivre mes investigations
    Merci d'avance !

  2. #2
    Admin' Général Supporter(rice)

    Date d'inscription
    septembre 2003
    Localisation
    ...dans mon TARDIS
    Organisme
    Bad Wolf
    Âge
    39
    Messages
    9 716

    Mes réseaux sociaux

    Follow Le Docteur On Twitter

    Par défaut Re : Installation Lizmap 3.2 / nginx

    Salut,

    Quelques pistes :

    - Selon les distros, tu peux avoir des groupe différents ou nginx a un groupe propre alors qu'apache est www
    - Le mode FPM de PHP 7 diffère de PHP5, il demande un fichier conf par domaine/sous domaine à configurer dans etc/php7/fpm/php-fpm.d

    Quand tu dis rien niveau logs, tu parles des logs lizmap ou nginx ? Il faut checker les deux

    @+
    >>>>>>>> Pas d'assistance technique par email ou mp : le forum est là pour ça <<<<<<<<<<<<


  3. #3

    Date d'inscription
    février 2012
    Emploi
    Administrateur SIG
    Organisme
    Agence d'urbanisme
    Messages
    50

    Mes réseaux sociaux

    Add infoble on Google+

    Par défaut Re : Installation Lizmap 3.2 / nginx

    Salut, tu es toujours au front à ce que je vois ! Merci en tout cas de me répondre.

    Alors pour l'utilisateur et le groupe j'ai bien www-data pour les 2.

    Pour le fpm, j'ai ajouté une conf distinct dans le pool.d mais je ne suis pas bien sur de la syntaxe du nom du pool (entre []), j'ai mis le même nom que mon fichier .tld dans sites-available...
    Cependant un fichier phpinfo() à la racine du sous-domaine me dit bien "Server API : FPM/FastCGI" et d'autre part la commande top à l'affichage de la page lizmap me donne :
    24760 www-data 20 0 45068 7944 5204 S 0.3 0.0 0:01.07 nginx
    24917 www-data 20 0 529924 104484 92868 S 0.3 0.4 0:12.48 php-fpm7.2
    26942 www-data 20 0 529428 101364 90368 S 0.3 0.4 0:02.35 php-fpm7.2
    donc le mode fpm a l'air d'être fonctionnel (j'ai par ailleurs un certain nombre de sites qui tournent sur d'autres domaines et sous-domaines sans aucun soucis)

    Pour ce qui est des logs, non rien ni dans ceux de nginx ni de lizmap...

    à+

  4. #4

    Date d'inscription
    février 2012
    Emploi
    Administrateur SIG
    Organisme
    Agence d'urbanisme
    Messages
    50

    Mes réseaux sociaux

    Add infoble on Google+

    Par défaut Re : Installation Lizmap 3.2 / nginx

    Bon finalement j'ai trouvé. Il y avait un souci avec la config du virtualhost et la prise en compte du pathinfo.
    Commenter la ligne du try_files dans le location ~ \.php {...} a pour l'instant résolu le problème.

  5. #5
    Admin' Général Supporter(rice)

    Date d'inscription
    septembre 2003
    Localisation
    ...dans mon TARDIS
    Organisme
    Bad Wolf
    Âge
    39
    Messages
    9 716

    Mes réseaux sociaux

    Follow Le Docteur On Twitter

    Par défaut Re : Installation Lizmap 3.2 / nginx

    Merci pour le suivi
    >>>>>>>> Pas d'assistance technique par email ou mp : le forum est là pour ça <<<<<<<<<<<<


 

 

Discussions similaires

  1. [WebMapping] Lizmap - Problème d'installation
    Par maverick83 dans le forum Assistance et Programmation
    Réponses: 1
    Dernier message: 04/05/2018, 11h09
  2. [QGIS Server] qgis-server et nginx
    Par infoble dans le forum Assistance et Programmation
    Réponses: 0
    Dernier message: 17/05/2017, 12h56
  3. [LizMap] Installation de Lizmap
    Par sylvainUTM dans le forum Assistance et Programmation
    Réponses: 1
    Dernier message: 22/04/2015, 12h22
  4. [LizMap] WMS sur LizMap
    Par Jiulin dans le forum Assistance et Programmation
    Réponses: 2
    Dernier message: 01/08/2014, 09h52
  5. [LizMap] pb Installation de Lizmap-web-serveur
    Par franck93 dans le forum Assistance et Programmation
    Réponses: 8
    Dernier message: 18/06/2014, 20h05

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •