Bienvenue! Inscrivez-vous et rejoignez notre communauté :)
  • Login:

Bienvenue sur Forum SIG - Systèmes d'Information Géographique et Géomatique.

Bienvenue sur le forumSIG. S'il s'agit de votre première visite, assurez vous de faire une recherche préalable dans les FAQ SIG. Vous devez vous inscrire avant de pouvoir poster.

Affichage des résultats 1 à 2 sur 2
  1. #1

    Date d'inscription
    mai 2007
    Localisation
    Montpellier
    Emploi
    Responsable R&D chez 3liz
    Organisme
    3liz
    Messages
    85

    Par défaut [Plugin Cadastre] Soucis avec dernière version de QGIS 2.18.10

    Bonjour,

    La dernière version de QGIS 2.18 a modifié un peu le comportement de l'outil DBManager (Gestionnaire de bases de données), qui est utilisé par le plugin Cadastre pour faire les requêtes (import, interrogation de parcelles, etc.).
    CF commit suivant : https://github.com/qgis/QGIS/commit/...7de1af9df8dcba

    Je viens de pousser un correctif dans la version "master" du plugin, qui permet au plugin de rester utilisable avant et après ce commit
    cf demande : https://github.com/3liz/QgisCadastrePlugin/issues/106

    Je vais sortir rapidement une version de correction 1.4.2

    NB: Je tenais à remercier toutes les personnes qui sont actives sur ce forum et qui prennent de leur temps pour répondre aux questions des utilisateurs du plugin Cadastre. Je n'ai pas été très actif ces derniers temps, alors je vous en remercie.

    Librement,
    Michaël

  2. #2
    Shérif adjoint Bob0x Supporter(rice)
    Date d'inscription
    juillet 2007
    Localisation
    Bretagne
    Emploi
    Chargé de mission environnement
    Âge
    35
    Messages
    844

    Par défaut Re : [Plugin Cadastre] Soucis avec dernière version de QGIS 2.18.10

    Bonjour,

    J'ai un problème avec le plugin cadastre version 1.3.0 et la version QGIS 2.18. Sur mon PC il n'y a pas de soucis, ce dernier semble bien fonctionner même si je ne l'ai pas fait beaucoup tourné.
    Sur le PC d'une collègue, je ne peux même pas installer l'extension, j'ai un message d'erreur qui m'indique qu'il y a un problème pyhton.
    Je pense que le problème doit être le suivant (désolé je ne connais pas beaucoup python...)
    Code:
    2018-03-12T14:46:28 1 Traceback (most recent call last):
    File "C:/PROGRA~1/QGIS2~1.18/apps/qgis-ltr/./python\qgis\utils.py", line 333, in startPlugin
    plugins[packageName] = package.classFactory(iface)
    File "C:/Users/NoemieB/.qgis2/python/plugins\cadastre\__init__.py", line 26, in classFactory
    from cadastre_menu import cadastre_menu
    File "C:/PROGRA~1/QGIS2~1.18/apps/qgis-ltr/./python\qgis\utils.py", line 607, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
    File "C:/Users/NoemieB/.qgis2/python/plugins\cadastre\cadastre_menu.py", line 29, in <module>
    from cadastre_dialogs import *
    File "C:/PROGRA~1/QGIS2~1.18/apps/qgis-ltr/./python\qgis\utils.py", line 607, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
    File "C:/Users/NoemieB/.qgis2/python/plugins\cadastre\cadastre_dialogs.py", line 39, in <module>
    from db_manager.db_plugins.plugin import DBPlugin, Schema, Table
    File "C:/PROGRA~1/QGIS2~1.18/apps/qgis-ltr/./python\qgis\utils.py", line 607, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
    File "C:/PROGRA~1/QGIS2~1.18/apps/qgis-ltr/./python/plugins\db_manager\db_plugins\__init__.py", line 75, in <module>
    initDbPluginList()
    File "C:/PROGRA~1/QGIS2~1.18/apps/qgis-ltr/./python/plugins\db_manager\db_plugins\__init__.py", line 48, in initDbPluginList
    DBPLUGIN_ERRORS.append(u"%s: %s" % (name, unicode(e)))
    UnicodeDecodeError: 'ascii' codec can't decode byte 0xe9 in position 29: ordinal not in range(128)
    Prince de la Bobox / Shérif adjoint Bob0x
    RIP Phoenix

 

 

Discussions similaires

  1. [QGIS 2.x] Un plugin cadastre libre pour QGIS !
    Par Le Docteur dans le forum Ressources
    Réponses: 132
    Dernier message: 05/03/2018, 08h31
  2. [QGIS 2.x] [Plugin cadastre] Script migration données version 1.4.1
    Par guenlm dans le forum Assistance et Programmation
    Réponses: 1
    Dernier message: 04/04/2017, 11h42
  3. [QGIS 2.x] Plugin Cadastre : charger une ancienne version
    Par tevrard dans le forum Assistance et Programmation
    Réponses: 4
    Dernier message: 24/02/2017, 11h14
  4. [QGIS 2.x] [Plugin Cadastre] Compatibilité des bases de données d'une version à l'autre
    Par Sylvain M. dans le forum Assistance et Programmation
    Réponses: 3
    Dernier message: 28/11/2014, 15h39
  5. [QGIS 2.x] Plugin cadastre: problème avec le zoom sur le groupe Cadastre
    Par odurr dans le forum Assistance et Programmation
    Réponses: 3
    Dernier message: 04/11/2014, 15h19

Les tags pour cette discussion

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •