Bienvenue! Inscrivez-vous et rejoignez notre communauté :)
  • Login:

Bienvenue sur Forum SIG - Systèmes d'Information Géographique et Géomatique.

Bienvenue sur le forumSIG. S'il s'agit de votre première visite, assurez vous de faire une recherche préalable dans les FAQ SIG. Vous devez vous inscrire avant de pouvoir poster.

Page 1 sur 2 12 DernièreDernière
Affichage des résultats 1 à 15 sur 19
  1. #1

    Date d'inscription
    février 2017
    Localisation
    Suisse
    Emploi
    Biologiste
    Âge
    25
    Messages
    25

    Par défaut impossible de charger l'extension processing

    Bonjour,

    J'ai un problème assez conséquent. Je voulais essayer de paramétrer l'outil laStool dans l'outil Traitement, j'ai donc voulu entrer c:/ lastool dans le champs comme sur cette image: http://docs.qgis.org/2.8/fr/_images/...ng_options.png sauf que là ça m'a fait un message d'erreur. Ensuite j'ai quitté qgis, et je l'ai rouvert. Maintenant, l'outil Traitement (sauf erreur correspondant à processing) a disparu et je reçois un message d'erreur me disant:

    " Imposible de charger l'extension processing provoque une erreur lors de l'appel de sa méthode classFactory()
    TypeError: coercing to Unicode: need string or buffer, NoneType found

    Traceback (most recent call last):
    File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 333, in startPlugin
    plugins[packageName] = package.classFactory(iface)
    File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/__init__.py", line 38, in classFactory
    return ProcessingPlugin(iface)
    File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/ProcessingPlugin.py", line 58, in __init__
    Processing.initialize()
    File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/Processing.py", line 148, in initialize
    Processing.addProvider(c())
    File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/Processing.py", line 103, in addProvider
    % (provider.getDescription(), traceback.format_exc()))
    File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/algs/saga/SagaAlgorithmProvider.py", line 123, in getDescription
    version = SagaUtils.getSagaInstalledVersion()
    File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/algs/saga/SagaUtils.py", line 130, in getSagaInstalledVersion
    commands = [os.path.join(sagaPath(), "saga_cmd -v")]
    File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/algs/saga/SagaUtils.py", line 75, in sagaPath
    if not os.path.isdir(folder):
    File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/genericpath.py", line 49, in isdir
    st = os.stat(s)
    TypeError: coercing to Unicode: need string or buffer, NoneType found

    Version de Python : 2.7.10 (default, Oct 23 2015, 19:19:21) [GCC 4.2.1 Compatible Apple LLVM 7.0.0 (clang-700.0.59.5)]
    Version de QGIS : 2.18.2 Las Palmas, exported

    Chemin Python :

    • /Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing
    • /Users/laurianedani/.qgis2/python/plugins/sextante_animove
    • /Applications/QGIS.app/Contents/MacOS/../Resources/python
    • /Users/laurianedani/.qgis2/python
    • /Users/laurianedani/.qgis2/python/plugins
    • /Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins
    • /Library/Frameworks/SQLite3.framework/Versions/C/Python/2.7
    • /Library/Frameworks/GEOS.framework/Versions/3/Python/2.7/site-packages
    • /Library/Python/2.7/site-packages/numpy-override
    • /Library/Python/2.7/site-packages/matplotlib-override
    • /Library/Frameworks/GDAL.framework/Versions/2.1/Python/2.7/site-packages
    • /Library/Python/2.7/site-packages/PySAL-1.13.0-py2.7.egg
    • /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python27.zip
    • /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7
    • /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-darwin
    • /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac
    • /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac/lib-scriptpackages
    • /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python
    • /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk
    • /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-old
    • /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload
    • /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC
    • /Library/Python/2.7/site-packages
    • /Users/laurianedani/.qgis2//python "


    J'ai essayé de désinstaller (en mettant qgis dans la corbeille; peut être que ça ne suffit pas et que je devrais désinstaller et réinstaler d'autres choses?) et réinstaller qgis mais ça n'aide en rien... savez vous comment réparer cette erreur??

    Quand je cherche processing dans extension, je ne peux pas la désinstaller et ça me dit qu'elle est corrompue :s


    edit: je ne sais pas comment, l'outil Traitement est réapparu dans ma barre d'outil, cependant l'erreur survient toujours quand je veux me rendre dans les options de l'outil et l'extension est toujours corrompue
    Dernière modification par laurianedani ; 07/03/2017 à 16h42.

  2. #2
    Modérateur et rédacteur Supporter(rice)


    Date d'inscription
    octobre 2005
    Localisation
    Louvain-la-neuve
    Emploi
    Géologue
    Organisme
    Université Catholique de Louvain - Région Wallonne
    Messages
    2 624

    Par défaut Re : impossible de charger l'extension processing

    Il est nécessaire de préciser que vous êtes sur Mac OS X et le chemin c:/ lastool est tout sauf un chemin Unixien (pour rappel Mac OSX est un système Unix...).

    Il y a 2 éléments importants

    - le dossier "masqué" qui se trouve dans le dossier /Utilisateurs/laurianedani/.qgis2 (voir les 2 dernières réponses dans Disparition d’extension )
    - le fichier de préférences /Utilisateur/laurianedani/Bibliothèque/Preferences/org.qgis.qgis2.plist

    En pratique, les extensions/plugins se trouvent dans le dossier /Utilisateurs/laurianedani/.qgis2/python/plugins, hormis pour certaines d'entre elles sur Mac qui se trouvent dans /Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing, ce qui est bien indiqué dans les messages d'erreur.

    Dans un premier temps, j'éliminerai donc le fichier de préférences.
    "Caminante, no hay camino, el camino se hace al andar" A. Machado

  3. #3

    Date d'inscription
    février 2017
    Localisation
    Suisse
    Emploi
    Biologiste
    Âge
    25
    Messages
    25

    Par défaut Re : impossible de charger l'extension processing

    oui effectivement j'ai pensé que le chemin c:/ ne fonctionnerait pas, j'ai un peu essayé à l'arrache car je ne savais pas quoi faire d'autre sauf que ça a tout fait planter ^^

    Super j'ai essayé de supprimer le fichier et maintenant tout fonctionne merci beaucoup!!
    Dernière modification par laurianedani ; 07/03/2017 à 17h37.

  4. #4
    Modérateur et rédacteur Supporter(rice)


    Date d'inscription
    octobre 2005
    Localisation
    Louvain-la-neuve
    Emploi
    Géologue
    Organisme
    Université Catholique de Louvain - Région Wallonne
    Messages
    2 624

    Par défaut Re : impossible de charger l'extension processing

    Oui, vous le copiez quelque part, puis vous le supprimez du dossier Préférences
    "Caminante, no hay camino, el camino se hace al andar" A. Machado

  5. #5

    Date d'inscription
    février 2017
    Localisation
    Suisse
    Emploi
    Biologiste
    Âge
    25
    Messages
    25

    Par défaut Re : impossible de charger l'extension processing

    Bon alors, le problème persiste ^^', je m'explique

    Je précise que j'ai eu ces problèmes quand j'ai voulu activer les outils pour les données LIDAR.
    Le tuto qgis indique d'aller dans les options de l'outil "traitement", de cliquer sur "fournisseurs de traitements" (ou prestataires suivant les versions), de cliquer sur "outil pour les données LIDAR", de cocher la case "activate" et d'indiquer le chemin vers le dossier LIDAR à côté du point "répertoire LAStools".
    J'ai placé mon dossier LIDAR à l'emplacement /Applications/LAStools , ne sachant pas trop où le mettre d'autre (et c'est d'ailleurs peut-être ça le problème?); c'est donc le chemin que j'ai indiqué.

    Cependant, une fois fait, je quitte QGIS et réouvre le programme, la même erreur python que montrée dans mes précédents postes apparaît et le dossier processing se trouve à nouveau dans préférences /Utilisateur/laurianedani/Bibliothèque/Preferences/org.qgis.qgis2.plist ... Du coup je resupprime le dossier, mais là ce que j'ai paramétré concernant les outils pour les données LIDAR ont disparu.

    Est-ce que je dois mettre le dossier LAStools ailleurs? Est-ce que le problème provient d'un autre endroit? Bref, comment faire marcher ces fichus outils pour traiter les données LIDAR ^^

  6. #6
    Modérateur et rédacteur Supporter(rice)


    Date d'inscription
    octobre 2005
    Localisation
    Louvain-la-neuve
    Emploi
    Géologue
    Organisme
    Université Catholique de Louvain - Région Wallonne
    Messages
    2 624

    Par défaut Re : impossible de charger l'extension processing

    Sans vouloir vous vexez, vous avez des sérieux problèmes avec Mac OS X

    1) LAStools n'est pas disponible nativement sur Mac OS X, alors qu'avez-vous installé dans /Applications/LAStools ?
    2) quel dossier avez-vous supprimé ? Il n'y a que le fichier org.qgis.qgis2.plist qui est concerné. Il s'agit simplement des préférences de QGIS, donc tous vos réglages ont disparaissent.

    En pratique donc tous les tutoriels ne sont pas bons pour Mac OS X ..., surtout ceux pour Windows

    En pratique, si vous voulez installer et utiliser LAStools, il faut soit le compiler vous-même, soit utiliser un gestionnaire de packages comme Homebrew (Liblas).
    Dernière modification par gene ; 09/03/2017 à 12h36.
    "Caminante, no hay camino, el camino se hace al andar" A. Machado

  7. #7

    Date d'inscription
    février 2017
    Localisation
    Suisse
    Emploi
    Biologiste
    Âge
    25
    Messages
    25

    Par défaut Re : impossible de charger l'extension processing

    haha oui en effet, je m'y connais très peu en informatique ^^ (en gros je sais utiliser mon ordi, mais en surface!)

    1) Voilà ce que j'ai fait: (d'après le tutoriel QGIS: http://docs.qgis.org/2.8/fr/docs/tra...sic_lidar.html)

    Fermez QGIS, si vous l’aviez déjà démarré.
    Une ancienne extension lidar devrait être installée par défaut sur votre système dans le dossier C:/Program Files/QGIS Valmiera/apps/qgis/python/plugins/processing/. (Dans le dossier processing, il n'y avait pas de lidar chez moi.)
    Si vous avez un dossier nommé lidar, supprimez-le. Ceci est valable pour les installations de QGIS 2.2 et 2.4. (pas de dossier lidar donc je n'ai rien supprimé)
    Rendez-vous au dossier exercise_data\forestry\lidar\, vous pouvez y trouver le fichier QGIS_2_2_toolbox.zip. Ouvrez-le et extrayez le dossier lidar pour remplacer celui que vous venez de supprimer. (j'ai simplement ajouté le dossier lidar dans processing)

    Vous devez maintenant installer LAStools sur votre ordinateur. Obtenez la nouvelle version ici http://lastools.org/download/lastools.zip et extrayez le contenu du fichier lastools.zip dans un dossier dans votre système, par exemple, c:\lastools\. Le chemin vers le dossier lastools ne doit pas avoir d’espace ou de caractères spéciaux. (Donc moi j'ai extrait le fichier lastools et je l'ai glissé dans application

    2) j'ai effectivement supprimé uniquement org.qgis.qgis2.plist ; ok alors si c'est les préférences ça explique pourquoi à chaque fois toutes mes extensions disparaissent et pourquoi je dois toujours recommencer =') Le problème ne vient donc pas du dossier en soit mais de ma manip sur qgis pour installer lastools.


    J'imagine donc que je dois soit installer LAStools au bon endroit?

  8. #8
    Admin' Portail Supporter(rice)

    Date d'inscription
    mars 2005
    Localisation
    Messanges
    Emploi
    Géomaticien
    Organisme
    CNRS
    Âge
    38
    Messages
    5 024

    Mes réseaux sociaux

    Follow Lud On Twitter

    Par défaut Re : impossible de charger l'extension processing

    Saur erreur de ma part, lastools n'est pas disponible ailleurs que sous windows et il n'est a priori pas compilable car les sources ne sont pas disponible, lastools n'est pas opensource il est même soumis à licence payante si on souhaite l'utiliser en dehors de la version de démo
    "comme j' dis toujours C'est pas parce que c'est sérieux que ça doit être lugubre..." Phyto
    --------------
    Vous avez le droit de poster sur différents forums mais prévenez nous qu'on ne perde pas de temps à faire les mêmes réponses !
    --------------
    Merci de respecter les règles du forum
    Un avis, une remarque sur la nouvelle version du PortailSIG, cliquez ici
    Vous souhaitez devenir rédacteur du PortailSIG, contactez moi

  9. #9

    Date d'inscription
    février 2017
    Localisation
    Suisse
    Emploi
    Biologiste
    Âge
    25
    Messages
    25

    Par défaut Re : impossible de charger l'extension processing

    oui en effet dans le tutoriel qgis ils mentionnent que, sans licence, il fonctionne mais on n'obtient des bandes diagonales sur le raster de sortie...

    Mhhhh si ce n'est dispo que sous windows, il va falloir que je trouve une autre alternative fonctionnant sur mac...

  10. #10
    Modérateur et rédacteur Supporter(rice)


    Date d'inscription
    octobre 2005
    Localisation
    Louvain-la-neuve
    Emploi
    Géologue
    Organisme
    Université Catholique de Louvain - Région Wallonne
    Messages
    2 624

    Par défaut Re : impossible de charger l'extension processing

    1)
    There are TWO parts to LAStools. One part is OPEN source (LGPL 2.1). The other part is CLOSED source and requires licensing for most commercial or government use
    En pratique, LAStools se trouve sur GitHub. Dans le dossier bin, il y a des versions compilées pour Windows, mais il est aussi précisé

    For Linux and MacOS
    the makefiles are included. Simply go into the root directory and run 'make':
    unzip LAStools.zip
    cd LAStools/
    make
    Sur Mac, il est aussi possible de l' installer avec le gestionnaire de package Homebrew

    Ce n'est donc pas simple d'installer LasTools sur autre chose qu'un système Windows

    2) Où avez-vous trouvé C:/Program Files/QGIS Valmiera/apps/qgis/python/plugins/processing/ sur Mac ?
    j'ai simplement ajouté le dossier lidar dans processing
    Ce dossier se trouve en réalité dans l'application -> /Applications/QGIS.app/Contents/Resources/python/plugins/processing

    3) quelle est votre version de QGIS, la dernière (2.18) , la version 2.8 du tutoriel ou les versions 2.2 ou 2.4 ? Il est clair qu'elles sont différentes et que vous ne pouvez pas installer ce qui est destiné à la version 2.2 sur une version de QGIS postérieure


    Pour moi, la solution est de tout supprimer, le fichier org.qgis.qgis2.plist, le dossier /Utilisateurs/laurianedani/.qgis2 et l'application puis de tout réinstaller en évitant les ...
    "Caminante, no hay camino, el camino se hace al andar" A. Machado

  11. #11
    Admin' Portail Supporter(rice)

    Date d'inscription
    mars 2005
    Localisation
    Messanges
    Emploi
    Géomaticien
    Organisme
    CNRS
    Âge
    38
    Messages
    5 024

    Mes réseaux sociaux

    Follow Lud On Twitter

    Par défaut Re : impossible de charger l'extension processing

    Bien vu gene, mais du coup tu ne peux avoir que les "open source tools" qui sont déjà plus ou moins présents avec liblas et laszip
    Sous mac, avez vous une version complète démo ?
    "comme j' dis toujours C'est pas parce que c'est sérieux que ça doit être lugubre..." Phyto
    --------------
    Vous avez le droit de poster sur différents forums mais prévenez nous qu'on ne perde pas de temps à faire les mêmes réponses !
    --------------
    Merci de respecter les règles du forum
    Un avis, une remarque sur la nouvelle version du PortailSIG, cliquez ici
    Vous souhaitez devenir rédacteur du PortailSIG, contactez moi

  12. #12
    Modérateur et rédacteur Supporter(rice)


    Date d'inscription
    octobre 2005
    Localisation
    Louvain-la-neuve
    Emploi
    Géologue
    Organisme
    Université Catholique de Louvain - Région Wallonne
    Messages
    2 624

    Par défaut Re : impossible de charger l'extension processing

    Non, tout ce qu'on peut faire, c'est exécuter les versions Windows avec Wine, et ça marche
    "Caminante, no hay camino, el camino se hace al andar" A. Machado

  13. #13
    Admin' Portail Supporter(rice)

    Date d'inscription
    mars 2005
    Localisation
    Messanges
    Emploi
    Géomaticien
    Organisme
    CNRS
    Âge
    38
    Messages
    5 024

    Mes réseaux sociaux

    Follow Lud On Twitter

    Par défaut Re : impossible de charger l'extension processing

    Citation Envoyé par gene Voir le message
    Non, tout ce qu'on peut faire, c'est exécuter les versions Windows avec Wine, et ça marche
    Je m'y refuse, pas de wine chez moi ;-)
    merci
    "comme j' dis toujours C'est pas parce que c'est sérieux que ça doit être lugubre..." Phyto
    --------------
    Vous avez le droit de poster sur différents forums mais prévenez nous qu'on ne perde pas de temps à faire les mêmes réponses !
    --------------
    Merci de respecter les règles du forum
    Un avis, une remarque sur la nouvelle version du PortailSIG, cliquez ici
    Vous souhaitez devenir rédacteur du PortailSIG, contactez moi

  14. #14

    Date d'inscription
    avril 2016
    Messages
    244

    Par défaut Re : impossible de charger l'extension processing

    Citation Envoyé par Lud Voir le message
    Je m'y refuse, pas de wine chez moi ;-)
    merci
    Mais ... mais... Je te croyais bourguignon

  15. #15
    Modérateur
    Date d'inscription
    novembre 2012
    Localisation
    Angers
    Messages
    607

    Par défaut Re : impossible de charger l'extension processing

    salut,
    Citation Envoyé par tevrard Voir le message
    Mais ... mais... Je te croyais bourguignon
    "Les maisons sont proches pour qu'on puisse aller chercher du feu." Proverbe Moba
    Avant de poster, lire au moins une fois : De la bonne manière de poser les questions

 

 
Page 1 sur 2 12 DernièreDernière

Discussions similaires

  1. [QGIS 2.x] Erreur Extension "Processing" QGIS 2.14
    Par IMSAF dans le forum Assistance et Programmation
    Réponses: 2
    Dernier message: 04/04/2016, 15h15
  2. [OpenJump 1.x] Impossible de charger plugin d'appariement Matching Extension
    Par baobazz dans le forum Assistance et Programmation
    Réponses: 2
    Dernier message: 08/02/2016, 14h43
  3. [QGIS 2.x] Impossible de charger l'extension Photo2Shape
    Par dooni dans le forum Assistance et Programmation
    Réponses: 7
    Dernier message: 10/08/2015, 08h41
  4. [QGIS 2.x] Erreur python : Impossible de charger l'extension processing
    Par slyarcheo dans le forum Assistance et Programmation
    Réponses: 1
    Dernier message: 01/10/2013, 09h26
  5. [MapServer] MapScript + IIS6 : Impossible de charger l'extension
    Par JeannoT79 dans le forum Assistance et Programmation
    Réponses: 4
    Dernier message: 20/09/2006, 10h00

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •