Bienvenue! Inscrivez-vous et rejoignez notre communauté :)
  • Login:

Bienvenue sur Forum SIG - Systèmes d'Information Géographique et Géomatique.

Bienvenue sur le forumSIG. S'il s'agit de votre première visite, assurez vous de faire une recherche préalable dans les FAQ SIG. Vous devez vous inscrire avant de pouvoir poster.

Affichage des résultats 1 à 4 sur 4
  1. #1

    Date d'inscription
    février 2014
    Messages
    1

    Par défaut Probléme d'installation Expire 1.3 / Débian

    Bonjour,

    Je tente d'installer Expire 1.3 dur un serveur Debian ...

    J'ai pris la version "pour serveur" (wget)
    je l'ai dézippé, j'ai changé les droits (chmod) des fichiers ...

    Et quand j'apelle la page d'index (http://monsite/Expire) dans mon navigateur j'ai une page blanche ...
    et ça dans mes logs d'erreur :

    PHP Fatal error: Cannot re-assign auto-global variable _POST in /var/www/default/www/Expire/lib/fonctions.php on line 141

    Et la ligne en question :
    function buildXML($racine, $nom_fichier, $nom_dossier, $_POST, $version = "2.3+") {

    Une idée ?

  2. #2
    Admin' Général Supporter(rice)

    Date d'inscription
    septembre 2003
    Localisation
    ...dans mon TARDIS
    Organisme
    Bad Wolf
    Âge
    38
    Messages
    9 710

    Mes réseaux sociaux

    Follow Le Docteur On Twitter

    Par défaut Re : Probléme d'installation Expire 1.3 / Débian

    Bonjour,

    Regardez dans la doc s'il ne vous manque pas une extension PHP à activer ?

    @+
    >>>>>>>> Pas d'assistance technique par email ou mp : le forum est là pour ça <<<<<<<<<<<<


  3. #3

    Date d'inscription
    août 2011
    Localisation
    Montpellier
    Emploi
    Développeur SIG
    Organisme
    CEFE-CNRS
    Messages
    1

    Mes réseaux sociaux


    Add cybernar on Linkedin

    Par défaut Re : Probléme d'installation Expire 1.3 / Débian

    Bonjour,
    je rencontre le même problème sur Windows avec WampServer et PHP 5.5.
    Je pense avoir trouvé l'origine du problème ici : http://stackoverflow.com/questions/2...-variable-post et là : http://php.net/manual/en/language.va...als.php#112184

    Since PHP 5.4, you cannot use a superglobal as the parameter to a function
    $_POST is globally accessible. So you don't have to pass to your function.
    - Une 1ère solution serait d'utiliser une version de PHP <= 5.3
    - Une 2nde solution serait de modifier les fonctions dont les paramètres comportent $_POST, dans le fichier fonctions.php du répertoire Expire/lib
    J'ai tenté cette dernière option en remplaçant $_POST par $dummy (pour ne pas avoir à modifier aussi les appels de fonctions ...).
    Cela semble fonctionner, à prendre au conditionnel quand même.

    Voici la liste des lignes que j'ai changées :

    ligne 141 : function buildXML($racine, $nom_fichier, $nom_dossier, $dummy, $version = "2.3+") {
    ligne 784: function boucler($dummy, $champs) {
    ligne 918: function getSystemeProj($dummy) {
    ligne 931: function setContact($dummy, $cible, $concerne, $doc) {
    ligne 1043: function setTypeGeometrie($dummy, $cible, $doc) {
    ligne 1183: function setContraintes($dummy, $cible, $concerne, $doc) {
    ligne 1229: function setMotsCles($dummy, $cible, $doc, $keywordType, $trad = false) {
    ligne 1542: function setThematiques($dummy, $cible, $doc) {
    ligne 1609: function setEmprise($dummy, $cible, $doc, $version) {
    ligne 1665: function setFormatSpecification($dummy) {
    ligne 1675: function setLiens($dummy, $cible, $doc) {
    ligne 1721 : function buildCatalogue($racine, $nom_fichier, $nom_dossier, $dummy) {
    ligne 1822: function setCatalogueAttributs($dummy, $cible, $doc) {
    ligne 1877: function bouclerFC($dummy) {
    J'obtiens un deprecated lié à PHPMailer au moment d'enregistrer la métadonnée, mais j'obtiens quand même mon fichier de métadonnées XML ... c'est le principal

    Cyril
    Dernière modification par cybernar ; 18/08/2014 à 17h41.

  4. #4
    Admin' Général Supporter(rice)

    Date d'inscription
    septembre 2003
    Localisation
    ...dans mon TARDIS
    Organisme
    Bad Wolf
    Âge
    38
    Messages
    9 710

    Mes réseaux sociaux

    Follow Le Docteur On Twitter

    Par défaut Re : Probléme d'installation Expire 1.3 / Débian

    Merci pour ton retour et ton aide pour le debug, je regarde pour changer les sources du logiciels
    >>>>>>>> Pas d'assistance technique par email ou mp : le forum est là pour ça <<<<<<<<<<<<


 

 

Discussions similaires

  1. [Expire 1.0.1] Installation sous Apache 2.2.17
    Par thomas26 dans le forum Assistance Technique
    Réponses: 1
    Dernier message: 29/04/2011, 09h28
  2. [Expire 1.x] Recommandations techniques et installation
    Par Grob dans le forum Assistance Technique
    Réponses: 9
    Dernier message: 23/09/2009, 19h28
  3. [GeoSource] Installation sous Debian
    Par cédille dans le forum Assistance Technique
    Réponses: 3
    Dernier message: 02/09/2009, 11h14
  4. [GRASS] Installation sous debian
    Par lilly dans le forum Assistance et Programmation
    Réponses: 1
    Dernier message: 27/10/2006, 15h53
  5. [MapServer] Installation sur Linux Debian
    Par Christophe dans le forum Assistance et Programmation
    Réponses: 8
    Dernier message: 11/04/2005, 16h01

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •