Bienvenue! Inscrivez-vous et rejoignez notre communauté :)
  • Login:

Bienvenue sur Forum SIG - Systèmes d'Information Géographique et Géomatique.

Bienvenue sur le forumSIG. S'il s'agit de votre première visite, assurez vous de faire une recherche préalable dans les FAQ SIG. Vous devez vous inscrire avant de pouvoir poster.

Affichage des résultats 1 à 6 sur 6
  1. #1

    Date d'inscription
    août 2010
    Localisation
    Brest
    Emploi
    Technicien SIG
    Organisme
    B.E. environnement, aménagement et urbanisme
    Âge
    28
    Messages
    360

    Par défaut Résolu : OLE DB plusieurs champs "BLOB"

    Bonjour à tous,

    Via une connexion OLE DB je souhaite interroger une base access .accdb (via arcgis v9.3.1 arcinfo).
    Le problème, c'est que je rencontre une erreur à l'ouverture de certaines tables =>
    Une erreur s'est produite durant le chargement des enregistrements.
    Cet enregistrement contient une valeur erronée. [OIDTable33]
    Cet enregistrement contient une valeur erronée. [photo]
    ArcGIS bloque donc sur un champs de type "BLOB" où sont stockés des images.
    Mais cela concerne seulement les tables ayant plusieurs champs de ce type.

    N'ayant rien trouvé sur ce sujet, quelqu'un aurait-il connaissance d'une telle limitation?
    Et, si oui, un moyen de contourner le problème, car là je sèche...

    D'avance merci,
    Martin

  2. "réponse de Mr ESRI

    " (...) obtenu une réponse définitive concernant l’utilisation des champs pièces jointes d’une base Access depuis une connexion oledb.

    ArcGis n’est pas capable d’interpréter correctement certains type de champ comme memo, pièces jointes et les converti automatiquement en BLOB.

    Jusqu’à la version 9.3.1 une table ne pouvait pas contenir plus d’un champ de ce type, ce qui explique le comportement rencontré.

    http://support.esri.com/en/knowledge...s/detail/23436

    A partir de la version 10 le contournement le plus approprié consistera à utiliser une couche de requête afin d’exclure les champs dont le type n’est pas supporté."
    :/
    Martin"


  3. #2
    Biblioman
    Date d'inscription
    mai 2005
    Localisation
    Villeurbanne
    Âge
    32
    Messages
    3 218

    Par défaut

    Cela fonctionnait avant et plus maintenant?
    Dernière modification par Speed-Popeye ; 15/04/2012 à 22h32.
    Home is where the .arc is...
    Propos sous license Beerware !!!

  4. #3

    Date d'inscription
    août 2010
    Localisation
    Brest
    Emploi
    Technicien SIG
    Organisme
    B.E. environnement, aménagement et urbanisme
    Âge
    28
    Messages
    360

    Par défaut

    Cela fonctionnait avant et plus maintenant?
    Non, echec dès la première tentative :/

    La seule chose que j'ai pu trouver avec mon moteur de recherche web, c'est :
    "Lors d'une prévisualisation dans ArcCatalog d'une table OLE DB ...
    support.esrifrance.fr/Articles/Arcgis/.../23436.htm
    Lors d'une prévisualisation dans ArcCatalog d'une table OLE DB, les noms de ... Ceci peut se produire lorsque la table OLE DB contient plus d'un champ BLOB."

    Mais pas moyen d'acceder à la ressource web -> Erreur de serveur 404 - Fichier ou répertoire introuvable.

    Je m'en retourne donc vers le support ESRI...

    Martin

  5. #4
    Biblioman
    Date d'inscription
    mai 2005
    Localisation
    Villeurbanne
    Âge
    32
    Messages
    3 218

    Par défaut

    Le support est effectivement la piste à creuser en priorité, votre problème étant peu courant et mal documenté, voire posséder une source incongrue (ex: http://forums.arcgis.com/threads/458...mp-Blob-Values).
    Home is where the .arc is...
    Propos sous license Beerware !!!

  6. #5

    Date d'inscription
    août 2010
    Localisation
    Brest
    Emploi
    Technicien SIG
    Organisme
    B.E. environnement, aménagement et urbanisme
    Âge
    28
    Messages
    360

    Par défaut

    Merci,
    J'attends donc la réponse du support, je la partagerais...

  7. #6

    Date d'inscription
    août 2010
    Localisation
    Brest
    Emploi
    Technicien SIG
    Organisme
    B.E. environnement, aménagement et urbanisme
    Âge
    28
    Messages
    360

    Par défaut

    réponse de Mr ESRI

    " (...) obtenu une réponse définitive concernant l’utilisation des champs pièces jointes d’une base Access depuis une connexion oledb.

    ArcGis n’est pas capable d’interpréter correctement certains type de champ comme memo, pièces jointes et les converti automatiquement en BLOB.

    Jusqu’à la version 9.3.1 une table ne pouvait pas contenir plus d’un champ de ce type, ce qui explique le comportement rencontré.

    http://support.esri.com/en/knowledge...s/detail/23436

    A partir de la version 10 le contournement le plus approprié consistera à utiliser une couche de requête afin d’exclure les champs dont le type n’est pas supporté."
    :/
    Martin

 

 

Discussions similaires

  1. [ArcGIS 10.x] Précision des champs x,y calculés avec "calculer la géométrie"
    Par bgaelle dans le forum Assistance Technique
    Réponses: 1
    Dernier message: 22/06/2013, 23h44
  2. [ArcGIS 9.x] Gestion des champs "null" dans un model builder
    Par anais4008 dans le forum Assistance Technique
    Réponses: 4
    Dernier message: 11/07/2011, 12h05
  3. [ArcGIS 9.x] Menu "Calcul de valeurs de champs" : problème de somme
    Par oyapock dans le forum Assistance Technique
    Réponses: 1
    Dernier message: 18/03/2011, 15h49
  4. [Access] Requête "création": attribuer une valeur unique à l'ensemble d'un champs
    Par Séb le dingue dans le forum Assistance et Programmation
    Réponses: 7
    Dernier message: 03/02/2011, 00h37
  5. [ArcGIS 9.x] Remplir un champ de type "Blob"
    Par Sylvain265 dans le forum Assistance Technique
    Réponses: 2
    Dernier message: 28/11/2007, 14h00

Les tags pour cette discussion

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •